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Using this guide

Review this section for basic information about this guide, as well as for general support contact
information.

About this guide

This guide describes how to get started using the Digi JumpStart for Microsoft .NET Micro Framework
as part of your product development.

For further instructions and samples of .NET applications, refer to on-line documentation.
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Who should read this guide

This guide is for software engineers and others who use Digi JumpStart for Microsoft .NET Micro
Framework. To complete the tasks described in this guide, you must:

m  Be familiar with installing and configuring software.
m  Have sufficient user privileges to do these tasks.

m  Be familiar with network software and development board systems.

Customer support

To get help with a question or technical problem with this product, or to make comments and
recommendations about our products or documentation, use the following contact information:

m  United States telephone: 1 877 912-3444
m International telephone: 1952 912-3444

m  Address: Digi International
11001 Bren Road East
Minnetonka, MN 55343 U.S.A.

= Web site: www.digiembedded.com
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Using the .NET Micro Framework

This guide takes you through the steps to compile, deploy, debug, and create a C# application for the Digi
Connect ME using the Digi JumpStart for Microsoft .NET Micro Framework.

Task 1: Get Ready

In this task you will make sure you have enough disk space and memory to install all necessary components to
run Microsoft .NET Micro Framework.

A successful installation requires a total of 10.1 GB on the install drive plus another 1GB on the system drive.
192MB RAM is minimum is required, but 256MB RAM recommended. Make sure your PC meets these
requirements.

What's next?

Go on to the next task to verify the contents of the JumpStart kit.
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Task 2: Verify the contents of the JumpStart Kit
In this task, you will verify the contents of the JumpStart kit.

The Digi JumpStart kit for Microsoft .NET Micro Framework kit includes hardware and software for using
Microsoft .NET Micro Framework. Verify these items are included in your JumpStart kit:

m  Digi JumpStart for Microsoft .NET Micro Framework installation CD

m  Digi Connect ME .NET Micro Framework Developer Embedded Module, part number
50000878-18

m  Microsoft Visual Studio 2005 Trial Version installation CDs

m  Digi Connect ME development board

m  12VDC power supply for the Connect ME development board
m  Ethernet cable

m  Serial cable

What's next?

If Microsoft Visual Studio 2005 has been previously installed on your PC, skip to Task 4, “Install Digi JumpStart
for Microsoft .NET Micro Framework.” Otherwise go on to the next task to install Microsoft Visual Studio 2005.
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Task 3: Install the Microsoft Visual Studio 2005 software

In this task, you will install Microsoft Visual Studio 2005. You must install Microsoft Visual Studio 2005
Standard (or better). You can use the Microsoft Visual Studio 2005 Professional (Trial Version) included in the

JumpStart kit.
I

Follow these steps to install Microsoft Visual Studio 2005.
1 Place Visual Studio installation Disc 1 into your CD drive, and follow the wizard prompts.

2 When you are prompted to select features to install, Microsoft Visual C# 2005 must be selected
at a minimum.

What’'s next?

Go on to the next task to install Digi JumpStart for Microsoft .NET Micro Framework.
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Task 4: Install Digi JumpStart for Microsoft .NET Micro Framework

In this task, you will install Digi JumpStart for Microsoft .NET Micro Framework on your PC. This can take a
couple of hours depending on what you already have installed on your PC and the speed of the PC.

To install Digi JumpStart for Microsoft .NET Micro Framework software place the Digi JumpStart for Microsoft
.NET Micro Framework installation CD into your CD drive, and follow the wizard prompts.

What’'s next?

Go on to the next task to setup the hardware.
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Task 5: Connect the hardware

In this task, you will connect components included in your JumpStart kit to your development board.

1 Insert the Digi Connect ME module, labeled 50000878-18, into the Digi Connect ME Development
board.
CAUTION: The Connect ME-MF sits loosely in the connector.
Make certain the module is inserted into the development board
prior to applying power.
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2 Follow the set up steps as illustrated below.

Add the appropriate plug and
Q connect power supply

Pe

To network

m <= f switch or hub —

Connect Ethernet cable
3 Connect the power supply to the outlet.

What's next?

Go to the next task to discover the IP address of the Digi Connect ME embedded module.
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Task 6: Discover the network IP address of the Digi Connect ME
In this task, you will discover the network IP address of the Digi Connect ME embedded module.

To discover the IP address of the Digi Connect ME:
1 Start MFDeploy by double clicking the ICON on the desktop.

The .NET Micro Framework Deployment Tool dialog opens.
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2 Select TCP/IP from the Device pull down menu. When the hour glass disappears, the discovery
process is complete and an IP address should appear in the text box next to the Device pull
down menu.

NMET Micro Framework Deployment Tool

Target  Options  Help

Dewvic
(EEE ) 10.52.35.75 - (00:40:3d:32 6c:cd) v/ _Ping | Erase |
—————

Image File

| vH_ Browsze... J[ Dreploy ]

LClear
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3 Your device may show up or you may have to look for it using the pull down menu. Verify this is
your Digi Connect ME embedded module by comparing the MAC address next to the discovered IP
Address, to the MAC address on top of the Digi Connect ME. If this is the MAC address of your
Connect ME, make note of the IP address for later use. If this is not the MAC address of your
unit, select another device from the pull down menu and check the MAC address next to the
discovered IP Address. If no devices are discovered, repeat step 2

Note:If you still cannot discover your device, go to the Troubleshooting section in Visual Studio
2005 online help. Launch Visual Studio 2005 and go to Help => Contents => Digi JumpStart for
Microsoft. Net Micro Framework: Connect ME => Troubleshooting.

What's next?

Go on to the next task to debug your first C# application.
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Task 7: Debug your first C# application
In this task, you will configure the GetNetworkinformation application to deploy over the network to your
specific Digi Connect ME module. You will also set a break point in the application, compile, deploy/debug the
application, and examine a local application variable.

To debug your first C# application:
1 Launch Microsoft Visual Studio 2005.
2 From the File pull down menu, select File => Open => Project/Solution \Program Files\Digi\Digi

JumpsStart for Microsoft .NET Micro Framework
\Samples\GetNetworkinformation\GetNetworkinformation.sin.
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3 Right mouse click on GetNetworkInformation in the Solution Explorer window, then click

Properties and the Application screen appears.

GetNetworkinformation - Microsoft Visual Studio

|<‘)[$GetNetworkInFormation.GetNetworkInformation v|| =@ Main()

File Edit Wew Refactor Project Buld Debug Data  Tools  ‘Window  Community  Help

@.J.Egﬂ # B39 -0 - B-F | b Debug » Any CPU ~ | [ ;_;
e — e TETE

G % by A | & '—EED@--Q-M#}@E}“}

Program.cs|  GethletworkInformation |~ Start Page | + X | Solution Explorer - Ge... » B X

using 3ystem.Threading;

using Microsoft.3SPOT;

using MNicrosoft.3POT.HNet;
using Microsoft.3POT.Hardware:

[namespace Micrasoft SPOT. Net Metwarkinformatian|
[ namespace GetNetworkInformation

{

public class GetletworkInformation

i
public static void Maini()
{

MNetworkInterface[] iface;

iface =

Iy

using Microsoft.SPOT.Hardware.DigiConnectMe;
using Microsoft.SPOT.Net.NetworkInformation;
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HetworkInterface,GethAllNetworkInterfaces () ;

|=d| Properties
[+3] References

C‘,Q Program.cs
=] ReadMe.tt
‘% Resources.r
< it

'-“lg DigiConnectMe, cs

esx ¥
3

Clseittion E... [@]Dynanic Help

Properties

AE

1 X

-




4 Click on the Micro Framework tab on the left and the Micro Framework screen appears.

GetNetworkInformation - Microsoft Yisual Studio
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File Edit ‘iew Project Buld Debug Data  Tools  Window  Community  Help
@'J'Egﬂ % B3 (R hq.rjvv:$ b Debug = firy CPU ~ | [ ;
Program.cs, GetNetworkInformation | Start Page | v X | Golution Explorer - Ge... » & X
; 2R &
Application o m Solution ‘GethetworkInformati
Configuration: | /A = § GetNetworkInformati
Buid [ [ Properties
Platform: | M/& . [l References
Buld Everts - ] DigiConnectMe.cs
Hissembly name: Default namespace: 4 | : '-]ﬁ Program.cs
Debug aethetwarkInformati | |GetNetworkInfnrmatio = Reahe.tx
[ (=4 Resources ress
Resources Output bype:
- < | ] >
i |Cunsule Application V| [ fssembly Informat
Settings Clsolution E... | @]Dynamic Help
Startup object: g
Reference Paths E Properties X
|(Nnt set) V|
1: Micra Framewark ) L _:I
\\‘-H‘H-‘ () Trame
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5 From the Transport pull down menu select TCP/IP, and from the Device menu enter the IP
address of the Connect ME from task 6. You should see this:

2% GetNetworkInformation, - Microsoft Visual Studio

File Edt Wiew Project Buld Debug Data  Tools  window  Community  Help

Bl-i-pEHE 4 a9 oo

=L b Debug + Ay CPU - | [

Program.cs /VGetNetworkInfurmatinn }/Start Page ]

» X || Solution Explorer - Ge... «

fpplication
Build

Build Everits
Debug
Resources
Settings

Reference Paths

BlaEA

Configuration: |.ﬁ.ctive (Debug)

m Salution 'Gethetwork

> ‘ B @ GetMetworkIn

Platfarm: |.ﬁ.ctive Ay CPUY

- =d| Properties

t- [l References
] DigiConnectt

3 ] Program.cs
=] Readie. bt

Deployrent

£ @ Resources.re

@ TCRIIP

¥ L | ]

@Solution E... D\,fna

@ 10.52,35.75

PR
jp Properties L]
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Save your changes by selecting File => Save All.

Enable the output window by selecting View => Ou
Double click Program.cs in the Solution Explorer w

29 GetMNetworkinformation - Microsoft Visual Studio

tput.
indow and your window should look like this:

| >

{
public class GetletworkInformation
{
public static woid Maing)
{

File Edt Vew Refactor Project Buld Debug Data Tooks Window Community Help
-l % Ga@ 908 b Dby ~ Ay CPU L) ;;
Dhbe #E8-2 00328684,
Program.cs| Gethetworkinformation  Start Page | w X | Solution Explarer - Sol.., » 8 X
qgGetNetworkInformation.GetNetworkInformation VH “igMain) @ 5?1
[ namespace GetNetworkInformation [ Solution ‘GethetwarkInfarr A

=8 @ GetNetworkInformi
[# [ Properties
¥ [id] References
igiCornectte.cs

" - : i . ; ReadMe.bxt
etworkInterface[] iface; = & I% Resources.resx ¥
e Ll E)
iface = NetworkInterface.GethillNetworkInterfaces(); ) 5
ﬂSolutmn E.. @Dynamlc Help
i
3 Propetties ~ 1 X
) o
< i | 3 i
Qutput ~1 X
Show output from:  Debug - z_?] ,;..J _‘, E =
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9 Right click to the left of the close bracket under the iface = statement and select
Breakpoint=> Insert Breakpoint.

2% GetNetworkInformation - Microsoft Yisual Studio

Fle  Edt

Wigw  Refackor

Project

Buld Debug Data

G-iE-Eld 2@ 980 b

Tools

Window  Community  Help
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- iy CPU - "
¥ ] =
== 0 e Tr aE
3 % b s ;EED\Z‘P—]"*-EQJ-C}*%&'*,IIE
GethetworkInformation - Program.cs| StartPage | » X || Salution Explorer - Sal... » B X
|<f$GetNetwnrkInFnrmatinn.GetNetwnrkInformation V” “igMain() V| @ 5?1
J] i m Solution ‘GethetworkInforr A
Al =
- public class GetletworkInformation =1 &~ @ GetNetworkInform
{ |=d| Properties
g public static void Main() # [l References =
{ '{ﬂ DigiCannectMe.cs
o] p .
HNetworkInterface[] iface; | é R;Dagdr;:,tcjt
4 [ 4 Resources.resy ¥
iface = HNetworkInterface,GetlllNetworkInterfaces(): — ] i l 3
@SDIution E... @Dynamic Help
Properties » 1 X
W
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10 Click the Start Debugging icon (the Green arrow) on the Toolbar to compile and deploy the
application to the Connect ME. After a short period, you should be stopped at your breakpoint,

11 Expand the iface variable in the local window on the bottom left, and you will see the network

and your screen should look like this:

% GethetworkInformation (Debugging) - Microsoft Visual Studio

h 2 face )

IP address setting of your device.
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Fle Edt ‘iew Project Buld Debug Dats Tools  indow  Commumity  Help
eapad saag.e. g0 1o 3
b u piafzt |G- iRbelEE=2 00303850
/ Program.cs& * X
0[3GetNetwurkInformatm‘GetNetworkInformahon v|| Main() V‘
public static void Main() :"
{ |
NetworkInterface[] iface;
iface = NetworkInterface.GetdllNetworkInterfaces();
Q ) a
)
' o
< Il ] 4
Locals -1 X| Irmed.. » B X
|W—\ ‘\n‘alue ‘Type
{Dimensions: 000000001+ Micrasoft




12 Select File => Close Solution.

What's next?

Go on to the next task to create a new C# application.
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Task 8: Create a new C# application
In this task, you will use the Digi Connect ME Template to create a new C# application.
1 From the file menu, select File => New => Project and the New Project window opens.

New Project

Project bypes: Templates: ||
- Visual C4

Yisual Studio installed templates

- Smart Device @Class Library @Console Application
- Starter Kits &\"“Device Emulator ﬁWindow Application
- Micro Framework,
. Web My Templates

[ Other Languages
[ Other Project Types

i 3earch Online Templates, .,

| <Ma description available =

2 Select Visual C# => Micro Framework under Project Types.
3 Select Digi Connect ME under My Templates.
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4 Enter the name of your new application in the Name field and select OK.
b5 Save your changes by selecting File => Save All.

6 Congratulations, you have completed the Getting Started procedure.

What's next?

You are now ready to develop your own C# applications for the Digi Connect ME. For instance, you can extend
and complete the new C# application created with the Digi Connect ME Template.

For other helpful information on developing C# applications for the Digi Connect ME, see the Reference

section in the Visual Studio Help Contents for the Digi JumpStart for Microsoft .NET Micro Framework:
Connect ME.
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