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• Screwdriver.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Visit our online Rabbit store at www.rabbit.com/store/ for the latest information on peripherals and acces-
sories that are available for the BL4S100 series of single-board computers.

Step 1 — Install Dynamic C®

Run a Sample Program
Once the BL4S100 is connected to your PC and to a power source, start Dynamic C by double-clicking on 
the Dynamic C icon on your desktop or in your Start menu. Select Store Program in Flash on the 
“Compiler” tab in the Dynamic C Options > Project Options menu. Then click on the “Communica-
tions” tab and verify that Use USB to Serial Converter is selected to support the USB programming 
cable. Select the COM port used for the USB connection in the dropdown menu under Options > 
Project Options, on the Communications tab, then click OK.

Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. 
Press function key F9 to compile and run the program.The STDIO window will open on your PC and will 
display a small square bouncing around in a box.

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs. Information on how 
to set up and use Digi’s ConnectPort™ X4 gateway and Application Note AN422, Using the iDigi™ 
BL4S100 Add-On Kit ZB with the ConnectPort™ X4 Gateway, are available on the www.digigreen.com 
Web site. Instructions for the sample programs and the source code are provided to allow you to modify 
them for your own use.

The BL4S100 User’s Manual included with the Dynamic C installation provides complete hardware 
reference information and describes the software function calls for the BL4S100. Sample programs 
specific to the operation of the BL4S100 are available in the Dynamic C SAMPLES\BL4S1xx folder.

The Digi® XBee USB identified in Chapter 2 of the BL4S100 User’s Manual and additional XBee ZB RF 
modules are available in a separate Rabbit-branded ZigBee Mesh Network Add-On Kit. These accessories 
can be used in a ZigBee network with the BL4S100.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the BL4S100 is powered correctly — the red power LED next to the power connector at J17 
should be lit when the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
PROG connector, not the DIAG connector, is plugged in to the programming port on the BL4S100 
with the marked (colored) edge of the programming cable towards pin 1 of the programming header.

• If a program compiles and loads, but then loses target communication before you can begin debugging, 
it is possible that your PC cannot handle the default debugging baud rate. Locate the Serial Options 
dialog in the Dynamic C Options > Project Options > Communications menu. Choose a lower 
debug baud rate.

Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. You should receive a Bios compiled 
successfully message once these steps are completed successfully. 

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Technical Bulletin Board and forums at www.rabbit.com/support/bb/ and at 
www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your BL4S100 or iDigi BL4S100 Add-On Kit ZB through a distributor or through 
a Rabbit partner, contact the distributor or partner first for technical support.
Rabbit, XBee, and Dynamic C are registered trademarks of Digi International Inc. iDigi is a trademakerk of Digi International Inc.
ZigBee is a registered trademark of the ZigBee Alliance.

Before doing any development, you must install Dynamic C. Insert the CD from the Add-On Kit in your 
PC’s CD-ROM drive. If the installation does not auto-start, run the setup.exe program in the root 
directory of the Dynamic C CD. Install any Dynamic C modules after you install Dynamic C.
iDigi™ BL4S100 Add-On Kit ZB
The iDigi X4 Starter Kit ZB combines Digi’s ConnectPort™ X4 gateway with the iDigi BL4S100 Add-On 
Kit ZB. The BL4S100 single-board computer in the iDigi BL4S100 Add-On Kit ZB illustrates the sharing 
of data with a ZigBee network via Digi’s ConnectPort™ X4 gateway. Sample applications are provided 
and can be used as a template for your own application.

Add-On Kit Contents
• BL4S100 Single-board computer with XBee ZB RF module.

• Getting Started instructions.

• Dynamic C® CD-ROM, with Rabbit-branded product documentation on disk.

• USB programming cable, used to connect your PC USB port to the BL4S100.

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).

• Demonstration Board with pushbutton switches and LEDs. The Demonstration Board can be 
hooked up to the BL4S100 to demonstrate the I/O and capabilities of the BL4S100.

• DB9 to bare leads serial cable.

• CAT 5/6 Ethernet crossover cable.

• Wire assembly to connect Demonstration Board to BL4S100.

http://www.zworld.com/support/bb/index.html
http://www.rabbitsemiconductor.com/forums/
http://www.zworld.com/support/questionSubmit.shtml
http://www.digigreen.com/
http://www.rabbit.com/store/


Figure 2.  Power Supply Connections

 adapter. The red LED next to the power connector at J17 should light up. The BL4S100 is now 
ed.

: Unplug the power supply while you make or otherwise work with the connections to the headers. 
l protect your BL4S100 from inadvertent shorts or power spikes.
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Hardware Connections
Step 1 — Connect Programming Cable
The programming cable connects the BL4S100 to the PC running Dynamic C to download programs and 
to monitor the BL4S100 module during debugging.

Connect the 10-pin PROG connector of the programming cable to header J8 on the BL4S100. Ensure that 
the colored edge lines up with pin 1 as shown. (Do not use the DIAG connector, which is used for monitor-
ing only.) Connect the other end of the programming cable to an available USB port on your PC or 
workstation.

Figure 1.  Connect Programming Cable and Power Supply

Your PC should recognize the new USB hardware, and the LEDs in the shrink-wrapped area of the USB 
programming cable will flash — if you get an error message, you will have to install USB drivers. Drivers 
for Windows XP are available in the Dynamic C Drivers\Rabbit USB Programming Cable\
WinXP_2K folder — double-click DPInst.exe to install the USB drivers. Drivers for other operating 
systems are available online at www.ftdichip.com/Drivers/VCP.htm.
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Plug in the AC
ready to be us

CAUTION
This wil
Step 2 — Connect Power
Once all the other connections have been made, you can connect power to the BL4S100.

First, prepare the AC adapter for the country where it will be used by selecting the plug. The Add-On Kit 
presently includes Canada/Japan/U.S., Australia/N.Z., U.K., and European style plugs. Snap in the top of 
the plug assembly into the slot at the top of the AC adapter as shown in Figure 2, then press down on the 
spring-loaded clip below the plug assembly to allow the plug assembly to click into place. Release the clip 
to secure the plug assembly in the AC adapter.

Connect the power supply to header J17 on the BL4S100 as shown in Figure 1. Be sure to match the latch 
mechanism with the top of the connector to header J17 on the BL4S100 as shown. The Micro-Fit® connec-
tor will only fit one way.

A hardware reset is done by unplugging the power supply, then plugging it back in, or by pressing the RESET 
button located next to the Ethernet jack.

http://www.ftdichip.com/Drivers/VCP.htm


Hardware Connections
Step 1 — Connect Programming Cable
The programming cable connects the BL4S100 to the PC running Dynamic C to download programs and 
to monitor the BL4S100 module during debugging.

Connect the 10-pin PROG connector of the programming cable to header J8 on the BL4S100. Ensure that 
the colored edge lines up with pin 1 as shown. (Do not use the DIAG connector, which is used for monitor-
ing only.) Connect the other end of the programming cable to an available USB port on your PC or 
workstation.

Figure 1.  Connect Programming Cable and Power Supply

Your PC should recognize the new USB hardware, and the LEDs in the shrink-wrapped area of the USB 
programming cable will flash — if you get an error message, you will have to install USB drivers. Drivers 
for Windows XP are available in the Dynamic C Drivers\Rabbit USB Programming Cable\
WinXP_2K folder — double-click DPInst.exe to install the USB drivers. Drivers for other operating 
systems are available online at www.ftdichip.com/Drivers/VCP.htm.

Step 2 — Connect Power
Once all the other connections have been made, you can connect power to the BL4S100.

First, prepare the AC adapter for the country where it will be used by selecting the plug. The Add-On Kit 
presently includes Canada/Japan/U.S., Australia/N.Z., U.K., and European style plugs. Snap in the top of 
the plug assembly into the slot at the top of the AC adapter as shown in Figure 2, then press down on the 
spring-loaded clip below the plug assembly to allow the plug assembly to click into place. Release the clip 
to secure the plug assembly in the AC adapter.

Connect the power supply to header J17 on the BL4S100 as shown in Figure 1. Be sure to match the latch 
mechanism with the top of the connector to header J17 on the BL4S100 as shown. The Micro-Fit® connec-
tor will only fit one way.
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Figure 2.  Power Supply Connections

Plug in the AC adapter. The red LED next to the power connector at J17 should light up. The BL4S100 is now 
ready to be used.

CAUTION: Unplug the power supply while you make or otherwise work with the connections to the headers. 
This will protect your BL4S100 from inadvertent shorts or power spikes.
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A hardware reset is done by unplugging the power supply, then plugging it back in, or by pressing the RESET 
button located next to the Ethernet jack.

http://www.ftdichip.com/Drivers/VCP.htm


iDigi™ BL4S100 Add-On Kit ZB
The iDigi X4 Starter Kit ZB combines Digi’s ConnectPort™ X4 gateway with the iDigi BL4S100 Add-On 
Kit ZB. The BL4S100 single-board computer in the iDigi BL4S100 Add-On Kit ZB illustrates the sharing 
of data with a ZigBee network via Digi’s ConnectPort™ X4 gateway. Sample applications are provided 
and can be used as a template for your own application.

Add-On Kit Contents
• BL4S100 Single-board computer with XBee ZB RF module.

• Getting Started instructions.

• Dynamic C® CD-ROM, with Rabbit-branded product documentation on disk.

• USB programming cable, used to connect your PC USB port to the BL4S100.

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).

• Demonstration Board with pushbutton switches and LEDs. The Demonstration Board can be 
hooked up to the BL4S100 to demonstrate the I/O and capabilities of the BL4S100.

• DB9 to bare leads serial cable.

• CAT 5/6 Ethernet crossover cable.

• Wire assembly to connect Demonstration Board to BL4S100.
Run a Sample Program
Once the BL4S100 is connected to your PC and to a power source, start Dynamic C by double-clicking on 
the Dynamic C icon on your desktop or in your Start menu. Select Store Program in Flash on the 
“Compiler” tab in the Dynamic C Options > Project Options menu. Then click on the “Communica-
tions” tab and verify that Use USB to Serial Converter is selected to support the USB programming 
cable. Select the COM port used for the USB connection in the dropdown menu under Options > 
Project Options, on the Communications tab, then click OK.

Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. 
Press function key F9 to compile and run the program.The STDIO window will open on your PC and will 
display a small square bouncing around in a box.

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs. Information on how 
to set up and use Digi’s ConnectPort™ X4 gateway and Application Note AN422, Using the iDigi™ 
BL4S100 Add-On Kit ZB with the ConnectPort™ X4 Gateway, are available on the www.digigreen.com 
Web site. Instructions for the sample programs and the source code are provided to allow you to modify 
them for your own use.

The BL4S100 User’s Manual included with the Dynamic C installation provides complete hardware 
reference information and describes the software function calls for the BL4S100. Sample programs 
specific to the operation of the BL4S100 are available in the Dynamic C SAMPLES\BL4S1xx folder.

The Digi® XBee USB identified in Chapter 2 of the BL4S100 User’s Manual and additional XBee ZB RF 
modules are available in a separate Rabbit-branded ZigBee Mesh Network Add-On Kit. These accessories 
can be used in a ZigBee network with the BL4S100.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the BL4S100 is powered correctly — the red power LED next to the power connector at J17 
should be lit when the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
PROG connector, not the DIAG connector, is plugged in to the programming port on the BL4S100 
with the marked (colored) edge of the programming cable towards pin 1 of the programming header.

• If a program compiles and loads, but then loses target communication before you can begin debugging, 
it is possible that your PC cannot handle the default debugging baud rate. Locate the Serial Options 
Rabbit, XBee, and Dynamic C are registered trademarks of Digi International Inc. iDigi is a trademakerk of Digi International Inc.
ZigBee is a registered trademark of the ZigBee Alliance.

020–0163 • 090330–A

• Screwdriver.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Visit our online Rabbit store at www.rabbit.com/store/ for the latest information on peripherals and acces-
sories that are available for the BL4S100 series of single-board computers.

Step 1 — Install Dynamic C®

Before doing any development, you must install Dynamic C. Insert the CD from the Add-On Kit in your 
PC’s CD-ROM drive. If the installation does not auto-start, run the setup.exe program in the root 
directory of the Dynamic C CD. Install any Dynamic C modules after you install Dynamic C.

dialog in the Dynamic C Options > Project Options > Communications menu. Choose a lower 
debug baud rate.

Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. You should receive a Bios compiled 
successfully message once these steps are completed successfully. 

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Technical Bulletin Board and forums at www.rabbit.com/support/bb/ and at 
www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your BL4S100 or iDigi BL4S100 Add-On Kit ZB through a distributor or through 
a Rabbit partner, contact the distributor or partner first for technical support.

http://www.zworld.com/support/bb/index.html
http://www.rabbitsemiconductor.com/forums/
http://www.zworld.com/support/questionSubmit.shtml
http://www.digigreen.com/
http://www.rabbit.com/store/



